From: Vlad Cojocaru (
Date: Fri Jan 13 2017 - 03:50:09 CST

Dear John,

Thanks a lot for your insights. The problem with openSUSE (and I believe
other distributions as well) is that they cannot use and distribute the
commercial drivers. But they do not force you to use Nouveau, they just
come with it by default. On openSUSE is in general straightforward to
remove Nouveau and install the proprietary drivers and NVIDIA has
repositories for it ...

In my case, the problem was that the graphical openSUSE installer did
not load at all on the machine with the Quadro M4000 (which was free of
any OS). So, I was forced to install the OS in textmode lacking any
graphical support. I assumed that this was because the lack of support
for the Quadro M4000 by the default drivers used by the SUSE installer
(the installer worked flawlessly on all other machines). When I compiled
the NVIDIA drivers on top of this textmode installation, at first the
machine still booted in textmode-only. I needed to change some settings
in the SUSE configuration, to get into the graphical mode. When I had
the graphical mode working, I noticed that VMD is very slow when loading
trajectories. However, soon after that I realized that the entire
graphics and not only VMD were just ridiculously slow for the
workstation specifications (though fast enough not to notice at first

I solved the issue by uninstalling the NVIDIA driver I initially
compiled on the textmode OS and reinstalling it (same version 375.26)
from the NVIDIA repositories for openSUSE ... Now it works perfect and
VMD is very fast on this machine even with quite large trajectories ...

I hope this thread will be helpful for others that may encounter similar

Best wishes

On 01/12/2017 07:32 PM, John Stone wrote:
> Hi Vlad,
> At present, if you want quad-buffered stereo display (e.g. with the
> 3D Vision monitors and shutter glasses), the Quadro GPUs are the only
> option. That said, I think there's a zero percent chance that any of this
> would work with the nouveau drivers. If OpenSUSE force you down the route
> of using the nouveau driver during installation, that's somewhat
> unfortunately, as I'm sure that any very new GPU model would end up being
> problematic, not just the Quadro 4000. In general I don't think that the
> nouvaeu drivers would be usable with VMD due to the diversity of advanced
> OpenGL features VMD uses. The performance anomalies you described would
> certainly be understandable based on my understanding of the maturity of
> the nouveau drivers vs. the commercial drivers. There are hundreds
> (maybe thousands?) of man-years of performance engineering incorporated in
> the commercial NVIDIA drivers that aren't in the nouveau drivers...
> The first thing we do installing any new machine is wipe away any trace of
> the nouveau drivers immediately replacing them with the NVIDIA drivers.
> I suspect things are going to remain this way for quite some time.
> The open source drivers like nouveau will probably never manage to
> close the performance gap with commercial drivers like NVIDIA's for
> OpenGL, as it is a huge API with a constantly evolving set of
> functionality and extensions. On the other hand, it is conceivable
> that nouveau and similar efforts for other GPUs might be more
> competitive for the new Vulkan graphics API (successor to OpenGL),
> as Vulkan is a much leaner, focused, and more minimalistic standard
> that specifically aims to address the complexity of OpenGL driver
> engineering that has gotten completely out-of-hand in the last decade.
> The challenge still remains for Vulkan to gain some footing, match some
> of the esoteric features of OpenGL that are still missing, and finally
> to get widely used in applications. We'll see how it goes...
> Cheers,
> John
> On Thu, Jan 12, 2017 at 04:02:31PM +0100, Vlad Cojocaru wrote:
>> Thanks Hannes, Thanks Giacomo,
>> .. for your thoughts/advices .. I think I solved the problem ... I
>> think the problem appeared because originally the openSUSE 42.2 could
>> not be installed with graphics because of the lack of support for the
>> Quadro M4000 by the default nouveau driver. I used a workaround to
>> install in text mode and then compile the NVIDIA driver on top of this
>> text installation ... With this, actually not only VMD but my entire
>> graphics were extremely slow. ...It was just more notable on VMD ...
>> What I did now was to switch to text mode, uninstall the NVIDIA driver
>> and install it again through the openSUSE 42.2 repositories ... Now, the
>> speed appears fine (actually is very fast) ..
>> Giacomo, the reason for having Quadro graphics was because I wanted to
>> have the 3D vision ... As far as I know on linux this is only possible
>> with Quadro cards ... If am wrong here or I am missing something, I'd be
>> grateful for an advice on a setup that works with GeForce and stereo
>> viewing.
>> Thanks again
>> Vlad
>> On 01/12/2017 03:47 PM, Hannes Loeffler wrote:
>>> Hi Vlad,
>>> I have a M4000 myself and Dell too (Precision 3620 but would need a
>>> closer look for the real specs). But I have only noticeable delays on
>>> start-up and and a bit after quit. But I think I had reported this here
>>> in a thread of yours.
>>> Other than that I have no problems. The vmd version is 1.9.3beta1.
>>> Driver version 370.28, compiled myself with CUDA 7.5. I had some
>>> strange timeouts when running pmemd, turned out to be the kernel
>>> version (currently I have 4.7.8).
>>> Have you tried to change any of those and see if that helps? You could
>>> also try some other CUDA accelerated software to see if you have
>>> problems with that.
>>> Cheers,
>>> Hannes.
>>> On Thu, 12 Jan 2017 14:40:45 +0100
>>> Vlad Cojocaru <> wrote:
>>>> Dear all,
>>>> I am experiencing a very awkward problem. I have a new Dell high end
>>>> workstation (Precision 7810). On this machine VMD (both 1.9.2 and
>>>> 1.9.3, either compiled from source or downloaded as pre-compiled
>>>> binaries is extremely slow. Practically, even loading a simple PDB
>>>> (3000 atoms) and drawing as New Cartoon with resolution 50 almost
>>>> freezes the VMD window, almost no rotation is possible anymore. This
>>>> machine has a Quadro M4000 graphics card (see details below). For a
>>>> comparison my older workstations with exactly same OS, same
>>>> configurations but with GeForce GTX950 or Quadro K4000 all VMD
>>>> executables tested (the same as on the new machine) run with no speed
>>>> issues whatsoever.
>>>> Has anyone experienced anything similar ? Are there some simple tests
>>>> one can do to pinpoint the potential issue ?
>>>> Best wishes
>>>> Vlad
>>>> Some details:
>>>> CPU: Intel(R) Xeon(R) CPU E5-2630 v3 @ 2.40GHz
>>>> RAM: 64 GB
>>>> Graphics: NVIDIA Quadro M4000 (driver 375.26, CUDA 8.0.44)
>>>> OS:OpenSUSE 42.2 (x86_64)
>> --
>> Vlad Cojocaru, Ph.D., Project Group Leader
>> Department of Cell and Developmental Biology
>> Max Planck Institute for Molecular Biomedicine
>> Röntgenstrasse 20, 48149 Münster, Germany
>> Tel: +49-251-70365-324; Fax: +49-251-70365-399
>> Email: vlad.cojocaru[at]

Vlad Cojocaru, Ph.D., Project Group Leader
Department of Cell and Developmental Biology
Max Planck Institute for Molecular Biomedicine
Röntgenstrasse 20, 48149 Münster, Germany
Tel: +49-251-70365-324; Fax: +49-251-70365-399
Email: vlad.cojocaru[at]