From: Andrea Spitaleri (
Date: Fri Oct 23 2015 - 07:35:06 CDT


I had more or less similar problem with nvidia/vmd/ubuntu-15.04. Please
refer to



On 23/10/2015 10:17, Pawel Kedzierski wrote:
> W dniu 23.10.2015 o 08:46, Bonakala Satyanarayana pisze:
>> Dear VMD developers, I have installed VMD in ubuntu 14.04. However, a
>> blank transparent display window is coming after execution of vmd. I
>> have an integrated graphics card in my laptop and I have installed
>> nvidia-304 drivers. Can anyone help me to get a proper display window
>> along with vmd-main.
> Dear Satya,
> This is only a guess based on the limited information you have
> provided, but it seems to me that you have an "Optimus technology"
> based laptop.
> If this is the case, you should install another software package which
> supports such configuration:
> sudo apt-get install bumblebee-nvidia
> It may be a good idea to purge nvidia-304 first, because the problem
> you see may be due to misconfiguration done by this package (without
> bumblebee it assumes that the nvidia GPU is available directly).
> The nvidia drivers will be pulled back by bumblebee-nvidia and it
> should configure your system properly (at least it did for me :)
> Note that to actually make vmd use the nvidia card, it should be run
> through "optirun" utility.
> I have a bash alias for this:
> alias vmd='optirun vmd'
> There is another supplement which gives improved performance, from
> package "primus"; when you install it, you should use "primusrun vmd".
> More information is to be found e.g. here:
> Cheers,
> Pawel
>> Regards
>> Satya

Andrea Spitaleri PhD
Istituto Computational mOdelling of NanosCalE and bioPhysical sysTems -
CONCEPT LabItaliano di Tecnologia
Via Morego, 30 16163 Genova
cell: +39 3485188790