From: John Stone (
Date: Sun Oct 18 2015 - 16:40:36 CDT

  Most likely, this should be updated to use the latest version of the
x3dom javascript renderer. I would suggest to try downloading one of
the latest ones, and then modify this line of the html accordingly:
  <script type='text/javascript' src='x3dom-1.7.0/x3dom.js'>

You can get newer revs of x3dom here:


On Sun, Oct 18, 2015 at 08:11:26PM +0200, Albert wrote:
> Hello:
> I've generated a .x3d file from VMD and inserted into a .html file with
> the following code:
> <head>
> <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
> A <title>This 3D model is created by VMD</title>
> A <link rel="stylesheet" type="text/css" href="x3dom-1.7.0/x3dom.css" />
> A <script type='text/javascript' src='x3dom-1.7.0/x3dom.js'> </script> A
> </head>
> A A A A
> <body>
> <p class="case">
> <!-- Use the same "x", "y", "width" and "height" attributes as SVG.
> A Optionally support the "viewBox" and "preserveAspectRatio" just like SVG
> -->
> <X3D xmlns="[1]"
> id="inline" showStat="true" x="0px" y="0px" width="1400px"
> height="1000px">
> A <Scene DEF='scene'>
> A A <Inline DEF="vmd" url="x3d/ACT-1003-8157.x3d" />
> A </Scene>
> </X3D>
> </p>
> A A
> </body>
> </html>
> This HTML file works file in Firefox, although the speed is not so good.
> However when I open it in IE or Google Chrome, it always claimed
> "loading...." but nothing displayed in the page after tens of minutes. I
> am just wondering, where is the problem?
> Thanks a lot
> References
> Visible links
> 1.

NIH Center for Macromolecular Modeling and Bioinformatics
Beckman Institute for Advanced Science and Technology
University of Illinois, 405 N. Mathews Ave, Urbana, IL 61801           Phone: 217-244-3349