From: John Stone (johns_at_ks.uiuc.edu)
Date: Fri Aug 07 2015 - 21:02:56 CDT

Hi,
  I think that something has gone wrong with your video driver
after the CentOS update. It looks like the NVIDIA version of
libGL.so got replaced by some CentOS-supplied library, and that's
why things have gone south. The easiest thing is just to reinstall
your video drivers and hopefully that'll cure the problem.

Cheers,
  John Stone
  vmd_at_ks.uiuc.edu

On Mon, Aug 03, 2015 at 05:31:41PM -0400, Joseph Baker wrote:
> Hi all,
>
> VMD was working fine for me on my Centos 6.6 machines until after a recent
> update. Now when I start VMD I am able to view my system in Cartoon
> representation, but NewCartoon does not work. Also, protein and water does
> not show in lines or points representation, however ions do show up in the
> points representation.
>
> I am getting the following output when starting VMD
>
> Info) VMD for LINUXAMD64, version 1.9.2beta1 (September 12, 2014)
> Info)
> [1]http://www.ks.uiuc.edu/Research/vmd/¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬
> Info) Email questions and bug reports to
> [2]vmd_at_ks.uiuc.edu¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬ ¬
> Info) Please include this reference in published work using VMD:¬ ¬
> Info)¬ ¬ ¬ Humphrey, W., Dalke, A. and Schulten, K., `VMD - Visual¬ ¬
> Info)¬ ¬ ¬ Molecular Dynamics', J. Molec. Graphics 1996, 14.1, 33-38.
> Info) -------------------------------------------------------------
> Info) Multithreading available, 24 CPUs detected.
> Info) Free system memory: 30442MB (94%)
> Info) Creating CUDA device pool and initializing hardware..
> Info) Detected 4 available CUDA accelerators:
> Info) [0] GeForce GTX TITAN Black 15 SM_3.5 @ 0.98 GHz, 6.0GB RAM, KTO,
> AE1, ZCP
> Info) [1] GeForce GTX TITAN Black 15 SM_3.5 @ 0.98 GHz, 6.0GB RAM, AE1,
> ZCP
> Info) [2] GeForce GTX TITAN Black 15 SM_3.5 @ 0.98 GHz, 6.0GB RAM, AE1,
> ZCP
> Info) [3] GeForce GTX TITAN Black 15 SM_3.5 @ 0.98 GHz, 6.0GB RAM, AE1,
> ZCP
> Warning) Detected X11 'Composite' extension: if incorrect display occurs
> Warning) try disabling this X server option.¬ Most OpenGL drivers
> Warning) disable stereoscopic display when 'Composite' is enabled.
> libGL error: failed to load driver: swrast
> Info) OpenGL renderer: GeForce GTX TITAN Black/PCIe/SSE2
> Info)¬ ¬ Features: STENCIL MSAA(4) MDE MTX NPOT PP PS
> Info)¬ ¬ GLSL rendering mode is NOT available.
> Info)¬ ¬ Textures: 2-D (16384x16384), 3-D (2048x2048x2048), Multitexture
> (4)
> Info) Dynamically loaded 2 plugins in directory:
> Info) /share/apps/vmd/lib192/plugins/LINUXAMD64/molfile
>
> If the most recent version of kernel-headers applied to the system helps
> in diagnosing this, it is
>
> kernel-headers-2.6.32-504.30.3.el6.x86_64
>
> I can provide additional info if necessary if you let me know what might
> be needed to help troubleshoot this. Thanks.
>
> Kind regards,
> Joe
> --
> Joseph Baker, PhD
> Assistant Professor
> Department of Chemistry
> C101 Science Complex
> The College of New Jersey
> Ewing, NJ 08628
> Phone: (609) 771-3173
> Web: [3]http://bakerj.pages.tcnj.edu/
>
> References
>
> Visible links
> 1. http://www.ks.uiuc.edu/Research/vmd/
> 2. mailto:vmd_at_ks.uiuc.edu
> 3. https://sites.google.com/site/bakercompchemlab/

-- 
NIH Center for Macromolecular Modeling and Bioinformatics
Beckman Institute for Advanced Science and Technology
University of Illinois, 405 N. Mathews Ave, Urbana, IL 61801
http://www.ks.uiuc.edu/~johns/           Phone: 217-244-3349
http://www.ks.uiuc.edu/Research/vmd/