From: Matic Kisovec (
Date: Thu May 07 2015 - 07:48:28 CDT

Dear Stefan,
Fortunately in my case I get the expected representation, for example 'NewCartoon'.

Thank you for the information anyway!

Best regards,

On 07. 05. 2015 11:34, Stefan Doerr wrote:
Also if you are still getting tube representation it might be a known bug in STRIDE where if your protein moves too far from the origin it messes up the SS prediction.

On Thu, May 7, 2015 at 7:41 AM, Matic Kisovec <<>> wrote:
Dear Daniel,

thank you for your suggestion. I added some RAM and now I don't get the STRIDE error anymore.
I still get that strange (to me at least) set of numbers mentioned in the first mail but that doesn't seem to cause any problems. I just don't remember seeing them but perhaps they are even a part of normal output.

Thank you for your time and have a nice day,
Matic Kisovec

On 06. 05. 2015 20:13, Daniel Möller wrote:

I’ve seen this output before and it’s caused by to less memory. For stride you need at least as much free memory as your current VMD with the loaded structure. I think, it’s because stride is an external programme which is called by VMD with exec and this results in a fork. So stride doesn’t have enough memory and crash.


Daniel Möller

Von:<> [] Im Auftrag von Matic Kisovec
Gesendet: Mittwoch, 6. Mai 2015 13:29
Betreff: vmd-l: Problem with assignation of secondary structure in VMD

Dear all,

I encounter an issue when I open and GROMACS trajectory (.gro + .xtc) and then try to colour aminoacid residues by secondary structure. Output is pasted below.
The trajectory loads just fine but there is a strange output right after the loading finishes (the numbers). Then when I select the option to colour the molecule by secondary structure I get the three ERROR lines. The entire structure changes colour to light grey and if I select 'NewCarton' representation there is no secondary elements (just a 'tube').

I can reproduce this with two of my trajectory files but not others that I tried so far. I suppose it could be an issue with my files. The other thing is that the trajectory is quite long (43 000 frames).

Has anybody else had similar issues? Any idea on how to fix this so I can get the SS properly coloured?

Thank you all and kind regards,

Info) Using plugin xtc for coordinates from file xyz.xtc
Info) Coordinate I/O rate 1328.7 frames/sec, 115 MB/sec, 32.2 sec
Info) Finished with coordinate file xyz.xtc.
{{1 0 0 -113.603} {0 1 0 -113.64} {0 0 1 -53.5547} {0 0 0 1}} {{1 0 0 0} {0 1 0 0} {0 0 1 0} {0 0 0 1}} {{0.012288 0 0 0} {0 0.012288 0 0} {0 0 0.012288 0} {0 0 0 1}} {{1 0 0 0} {0 1 0 0} {0 0 1 0} {0 0 0 1}}
0 1
Info) In any publication of scientific results based in part or
Info) completely on the use of the program STRIDE, please reference:
Info) Frishman,D & Argos,P. (1995) Knowledge-based secondary structure
Info) assignment. Proteins: structure, function and genetics, 23, 566-579.
ERROR) Unable to find Stride output file: /tmp/filegxwJFP
ERROR) Stride::read_stride_record: unable to read output file from Stride
ERROR) Call to Stride program failed.