From: Ivan Gregoretti (
Date: Thu Jul 31 2014 - 07:31:04 CDT

Hi Kshatresh,

There seems to be a configuration problem. Two hints to that:

1) "Tk startup error" and
2) being unable to find "/usr/local/lib/vmd/scripts/

Now, towards solving the problem

it says that for linux you need to edit the "configure" file that came
with the VMD tar archive.

For instance, in my Fedora box, this is an excerpt of my "configure" file

# Directory where VMD startup script is installed, should be in users' paths.

# Directory where VMD files and executables are installed

In my system (which works fine) I can do:

ls vmd-1.9.2a35
Announcement configure.options doc LINUXAMD64 proteins scripts
bin data lib msvc python shaders
configure distrib LICENSE plugins README src

and also the vmdinit.tcl can be found:

stat /usr/local/lib/vmd/scripts/vmd/vmdinit.tcl
  File: ‘/usr/local/lib/vmd/scripts/vmd/vmdinit.tcl’
  Size: 11567 Blocks: 24 IO Block: 4096 regular file
Device: fd01h/64769d Inode: 2103623 Links: 1
Access: (0644/-rw-r--r--) Uid: ( 1000/igregore) Gid: ( 1000/igregore)
Context: unconfined_u:object_r:lib_t:s0
Access: 2014-07-31 08:22:43.396699329 -0400
Modify: 2011-04-12 21:40:15.000000000 -0400
Change: 2014-03-06 09:01:29.882829327 -0500
 Birth: -

Is that how your system is configured and responding? Does proper
editing of your "configure" file solve the problem?

I hope this helps.


Ivan Gregoretti, PhD

On Thu, Jul 31, 2014 at 6:56 AM, Kshatresh Dutta Dubey
<> wrote:
> Dear Users ,
> I have installed vmd 1.9.1 on centos 7.0. It is showing several error
> during start up in vmd shell and some of the features like extension is
> missing. Following is the log of vmd start:
> Info) VMD for LINUXAMD64, version 1.9.1 (February 1, 2012)
> Info)
> Info) Email questions and bug reports to
> Info) Please include this reference in published work using VMD:
> Info) Humphrey, W., Dalke, A. and Schulten, K., `VMD - Visual
> Info) Molecular Dynamics', J. Molec. Graphics 1996, 14.1, 33-38.
> Info) -------------------------------------------------------------
> Info) Multithreading available, 12 CPUs detected.
> Info) Free system memory: 29679MB (92%)
> Info) Creating CUDA device pool and initializing hardware...
> CUDA error: invalid device symbol, line 62
> Info) Detected 1 available CUDA accelerator:
> Info) [0] GeForce GTX 680 8 SM_3.0 @ 1.14 GHz, 2.0GB RAM, KTO, OIO, ZCP
> Warning) Detected X11 'Composite' extension: if incorrect display occurs
> Warning) try disabling this optional X server feature.
> Info) OpenGL renderer: GeForce GTX 680/PCIe/SSE2
> Info) Full GLSL rendering mode is available.
> Info) Textures: 2-D (16384x16384), 3-D (2048x2048x2048), Multitexture (4)
> ERROR) Tk startup error: this isn't a Tk applicationunknown color name
> ERROR) Could not read the vmd initialization file -
> ERROR) source {/usr/local/lib/vmd/scripts/vmd/vmdinit.tcl}
> ERROR) can't invoke "wm" command: application has been destroyed
> ERROR) The VMDDIR environment variable is set by the startup
> ERROR) script and should point to the top of the VMD hierarchy.
> ERROR) VMD will continue with limited functionality.
> ERROR) invalid command name "vmd_load_extension_packages"
> Please help me to solve this issue. Thanks in advance.
> --
> Regards
> Kshatresh