From: Axel Kohlmeyer (
Date: Mon Apr 14 2014 - 12:06:42 CDT

On Mon, Apr 14, 2014 at 6:10 PM, Joshua Dempster
<> wrote:
> Hi,
> I downloaded VMD 1.9.1 for Windows and it doesn't seem to support HOOMD xml
> files. I tried downloading and installing Axel Kohlmeyer's plugin, no luck.

it worked the last time somebody tried it and i (cross-)compiled it. i
don't use windows, so cannot easily debug it. if you want help, you
need to provide more detailed information (what you did exactly to
install the plugin, what version of VMD exactly, what file you tried
to use, what startup message VMD prints, what error - if any - on the
console you get).

> I thought VMD natively supported HOOMD from 1.8.7 on for all platforms. Is
> that not the case?

support is included in molfile plugin library, yes. since the plugin
depends on an external library (xml is such a horrible construct to
parse, that i refuse to lose my sanity to write a parser for that), it
is not linked in statically. for platforms (e.g. linux) that usually
provide a compatible xml library natively, the plugin is bundled as a
dynamically loaded plugin (only). the same is true for a few select
other plugins with the same boundary conditions. since windows
doesn''t have the same xml library natively and it is a significant
pain to build VMD (or anything) in a portable way, the hoomd plugin is
not included on windows.

hope that clears up matters.


> Thanks,
> Josh

Dr. Axel Kohlmeyer
College of Science & Technology, Temple University, Philadelphia PA, USA
International Centre for Theoretical Physics, Trieste. Italy.