From: Maxim Belkin (mbelkin_at_ks.uiuc.edu)
Date: Sun Mar 02 2014 - 17:54:44 CST

Hi Carolyn,

The issue you are facing is caused by CUDA drivers. Try installing the latest CUDA 5.5.43 drivers. Until this version, CUDA didnít work on a great deal of GPUs under Mavericks.

Maxim

On Mar 2, 2014, at 4:54 PM, Phillips, Carolyn L. <cphillips_at_anl.gov> wrote:

> A little search turned up these versions.
>
> ./NVIDIA/CUDA-5.5/lib/libcudart.dylib
> ./VMD 1.9.1.app/Contents/vmd/libcudart.dylib
> ./MATLAB_R2013b.app/bin/maci64/libcudart.dylib
> /local/cuda/lib/libcudart.dylib
>
> I think the first it the one it should be finding.
> I donít know why such a library is included in vmd, but I am going to assume its legitimate
> Same for the Matlab one
> I assume it may be the /local version that is creating the problem.
>
> FYI,
>
> which nvcc
> /Developer/NVIDIA/CUDA-5.5/bin/nvcc
>
> -Carolyn
> On Mar 2, 2014, at 3:20 PM, Axel Kohlmeyer <akohlmey_at_gmail.com> wrote:
>
>> On Sun, Mar 2, 2014 at 3:42 PM, Phillips, Carolyn L. <cphillips_at_anl.gov> wrote:
>>> Hello,
>>>
>>> I am trying to pin down why my version of VMD 1.91.1 built from source has
>>> started seg faulting. (Note, i cannot run vmd -debug because gdb is no
>>> longer included with Xcode on Mavericks as a command line tool, you can get
>>> it from macports but it is now called ggdb )
>>>
>>> I started with verifying if I download and run the VMD1.9.1 binary that it
>>> still works. What I found is that this version does work, MacOS X OpenGL
>>> (32-bit Intel x86) (Apple MacOS-X 10.5.x or later).
>>>
>>> This version crashes, MacOS X OpenGL, CUDA (32-bit Intel x86) (Apple
>>> MacOS-X 10.5.x or later with CUDA)
>>>
>>> It cannot seem to interface with the cuda library correctly
>>>
>>> /Volumes/VMD-1.9.1/VMD\ 1.9.1.app/Contents/MacOS/startup.command ; exit;
>>> dyld: Library not loaded: @executable_path/libcudart.dylib
>>> Referenced from: /Volumes/VMD-1.9.1/VMD
>>> 1.9.1.app/Contents/MacOS/../Resources/VMD.app/Contents/MacOS/VMD
>>> Reason: Incompatible library version: VMD requires version 1.1.0 or later,
>>> but libcudart.dylib provides version 0.0.0
>>
>> hi carolyn,
>>
>> this looks like VMD picks up some old and incompatible version of the
>> cuda runtime library from somewhere.
>>
>> axel.
>>
>>
>>> /Volumes/VMD-1.9.1/VMD 1.9.1.app/Contents/MacOS/startup.command: line 7:
>>> 2533 Trace/BPT trap: 5 "$p/../Resources/VMD.app/Contents/MacOS/VMD" $*
>>> logout
>>>
>>> [Process completed]
>>>
>>>
>>> My system is
>>>
>>> Mac OSX 10.9.1
>>> Graphics NVIDIA GeForce GT 750M 2048 MB
>>> Processor 2.3 GHz Intel Core i7
>>>
>>>
>>> -Carolyn
>>
>>
>>
>> --
>> Dr. Axel Kohlmeyer akohlmey_at_gmail.com http://goo.gl/1wk0
>> College of Science & Technology, Temple University, Philadelphia PA, USA
>> International Centre for Theoretical Physics, Trieste. Italy.
>