From: Robert Wohlhueter (
Date: Thu Aug 05 2010 - 17:01:20 CDT

Thanks, John, you were right on.

I had indeed upgraded to 195.36.24 via the Ubuntu synaptic package
manager. Went back to NVIDIA - whose latest release for 64-bit Linux
is 256.44 - and that gave me immediate gratification.


John Stone wrote:
> Bob,
> This error is coming from NVIDIA CUDA libraries, not from VMD...
> Apparently something is amiss with your new driver installation.
> My recommendation is to go through it again and make sure you
> don't have any leftover stuff from the old driver. Also, when in doubt,
> get the drivers directly from NVIDIA's web site, and not through your
> linux distribution. The linux distributions have been known to break
> things vs. the original versions obtained directly from NVIDIA.
> If the version your installing came straight from NVIDIA, then
> I'd recommend looking through the driver package README info carefully
> and verify you haven't missed anything important.
> Cheers,
> John Stone
> On Thu, Aug 05, 2010 at 05:04:53PM -0400, Bob Wohlhueter wrote:
>> [running VMD 1.8.7 under Linux 10.04 with NVIDIA geforce GTX 275]
>> Starting vmd used to find CUDA device, but recently I upgraded my NVIDIA driver. Subsequently when I start vmd I get:
>> Error: API mismatch: the NVIDIA kernel module has version 195.36.24,
>> but this NVIDIA driver component has version 195.36.15. Please make
>> sure that the kernel module and all NVIDIA driver components
>> have the same version.
>> Info) No CUDA accelerator devices available.
>> I suppose I could revert to NVDIA driver version 195.36.15, but it would seem more rational to bump the vmd driver component up to .24. But I can't figure out how to do that.
>> Bob Wohlhueter