From: John Stone (johns_at_ks.uiuc.edu)
Date: Tue Feb 09 2010 - 09:29:32 CST

Hi guys,
  So, I just tested Axel's structure with a few pre-release versions of VMD 1.8.7
as well as the older VMD 1.8.6 and 1.8.5 versions, and on my Linux machine, the problem
occurs on all of them, even VMD 1.8.6 and 1.8.5.

Interestingly, I find that if I create a fresh Viewmaster saved
session using VMD 1.8.4, it will load and display correctly in all
of the versions I've tested: VMD 1.8.4, 1.8.5, 1.8.6, and 1.8.7.....
I presume this may also be the case for viewmaster sessions created
with later versions up to some point.

So, there's something about the contents of the saved session from
the new 1.8.7 version that's poisoning all these versions when loaded.
I'll have to figure out what it is and get back to you.

In my testing so far, the symptoms appear to be corruption of OpenGL
state. The VMD GUI menus all work for me, but the OpenGL window
is not displaying correctly. I have gone through a number
of state changes and gotten it to partially recover, but that seems to be
the root of the problem I'm seeing in all of the versions I've tested so far.

Cheers,
  John

On Tue, Feb 09, 2010 at 09:24:14AM -0500, Axel Kohlmeyer wrote:
> On Tue, 2010-02-09 at 09:47 +0000, Christopher McLean wrote:
>
> chris,
>
> > Thanks for the feedback Axel,
> >
> >
> >
> > The user is on:
> >
> > Kernel: 2.6.31-19-generic-pae (i686)
> >
> > Distro: Ubuntu 9.10
> >
> > VMD for LINUX, version 1.8.7 (August 1, 2009)
>
> ok. so that means it is not only one architecture
> (i run on x86_64) and one kind of linux.
>
> >
> > It is not possible at this moment to move this user to another
> > environment, although we could test dev builds on this machine if
>
> i already tested the latest development sources. it has to be
> something that was broken during the development of 1.8.7.
> that was a very long development cycle and some changes to how
> molecules are initialized were made.
>
> it might be useful to install the previous version of vmd
> as vmd-1.8.6 in parallel to the current version (which is
> still recommended to use for everything else) so that your
> user can keep working (that is what i often do in such cases).
>
> > needed. Should a bug report be filed for this or is this list
> > monitored by the devs? Am happy to provide any further information as
> > needed
>
> for the most part there is just _the_ "dev", john stone,
> and he is very good at keeping track of what is going on.
> he is also very busy. it looks like a very odd bug, perhaps
> related to some internal state. outside of him there are
> very few people that have looked into the intestines of VMD
> deep enough and are still actively working on it.
>
> i have uploaded a viewmaster session file to the VMD public
> biofs under testfiles/akohlmey/viewmaster-bug/
> that will hopefully make it easier to track it down.
>
> cheers,
> axel.
>
>
> >
> >
> > Regards
> >
> >
> >
> > Chris
> >
> >
> >
> > > -----Original Message-----
> >
> > > From: Axel Kohlmeyer [mailto:akohlmey_at_gmail.com]
> >
> > > Sent: 08 February 2010 17:48
> >
> > > To: Christopher McLean
> >
> > > Cc: 'vmd-l_at_ks.uiuc.edu'
> >
> > > Subject: Re: vmd-l: Blank thumbnails and non-working snapshots
> >
> > >
> >
> > > On Mon, 2010-02-08 at 15:55 +0000, Christopher McLean wrote:
> >
> > > > Hi,
> >
> > >
> >
> > > hi chris,
> >
> > >
> >
> > > > One of our students is having issues with the ViewMaster plugin.
> > When
> >
> > > > snapshots are taken, and the project saved, upon reloading, the
> >
> > > > thumbnails are blank and clicking one of the thumbnails does not
> >
> > > > reload the view. The thumbnails look fine upon creation before
> >
> > > > save/reload.
> >
> > >
> >
> > > confirmed. i see the same thing here on a fedora 12 x86_64 machine
> >
> > > with the current development code. after reloading the state, some
> >
> > > more things seem to be broken. like new representations can only be
> >
> > > created for lines and points.
> >
> > >
> >
> > > unfortunately, i cannot give any pointers as to how to resolve this.
> >
> > > it looks like something deep inside of VMD is going wrong. using
> >
> > > valgrind doesn't show anything unusual.
> >
> > >
> >
> > > can you please check what platform your user is using, and perhaps
> >
> > > have him or her try a different platform? that could provide a hint
> >
> > > where to look.
> >
> > >
> >
> > > thanks,
> >
> > > axel.
> >
> > > >
> >
> > > > Any help or pointers would be appreciated.
> >
> > > >
> >
> > > >
> >
> > > >
> >
> > > > Regards
> >
> > > >
> >
> > > >
> >
> > > >
> >
> > > > Chris
> >
> > > >
> >
> > > >
> >
> > > >
> >
> >
>
> --
> Dr. Axel Kohlmeyer akohlmey_at_gmail.com
> Institute for Computational Molecular Science
> College of Science and Technology
> Temple University, Philadelphia PA, USA.

-- 
NIH Resource for Macromolecular Modeling and Bioinformatics
Beckman Institute for Advanced Science and Technology
University of Illinois, 405 N. Mathews Ave, Urbana, IL 61801
Email: johns_at_ks.uiuc.edu                 Phone: 217-244-3349
  WWW: http://www.ks.uiuc.edu/~johns/      Fax: 217-244-6078