Re: Need help with errors in REST2 sample file

From: Han, Yuwei (yuwei.han17_at_imperial.ac.uk)
Date: Mon Oct 28 2019 - 02:28:15 CDT

Hey,
I just realized that I was supposed to use NAMD version more than 2.10, but actually I was using NAMD 2.9. So the problem with not valid variables solved. However, I still have to tackle the problem with the TCL script. Following are my problems. It would be very nice if you can have a look of it!

FATAL ERROR: can't read "restart_root": no such variable
    while executing
"format "$restart_root.tcl" """
    ("while" body line 100)
    invoked from within
"while {$i_run < $num_runs} {
# if { $i_run == 0 } {
# minimize 100
# run 100
# }
  if { $i_run % 2 == 0 } {
    set swap a; set other b
  } el..."
    (file "rest2_remd.namd" line 106)
    invoked from within
"source rest2_remd.namd "
    invoked from within
"if { ! [catch numPes] } { source rest2_remd.namd }"
    (file "job0.conf" line 4)
Best
Yuwei
________________________________
From: owner-namd-l_at_ks.uiuc.edu <owner-namd-l_at_ks.uiuc.edu> on behalf of Han, Yuwei <yuwei.han17_at_imperial.ac.uk>
Sent: 23 October 2019 06:23
To: Chitrak Gupta <chgupta_at_mix.wvu.edu>; Chandni Tiwari <chandni.tiwari_at_monash.edu>
Cc: namd-l_at_ks.uiuc.edu <namd-l_at_ks.uiuc.edu>
Subject: Re: namd-l: Need help with errors in REST2 sample file

Hey,
Thank you for telling me this. I've checked my configuration file, I think the error parameters, except soluteScalingFactor, are included.
soluteScaling on
soluteScalingCol O
soluteScalingFile aaqaa3.spt

soluteScalingAll no

By the way, I have to say that all of the configuration files are from the example files supplied by NAMD. They supposed to be well defined before publishing, right? The example file is just in lib/replica/REST2/rest2_remd.namd, and I followed the NAMD 2.13 user's guides. Actually, I met problems more than what I mentioned. The first problem I met is in the script file, and I met the errors I showed you before after I solved it. If you don't mind, can you please help me go through the example since, for me, I really want a REST2 example that I can trust.

Reason: FATAL ERROR: missing close-brace: possible unbalanced brace in comment
    while executing
"while {$i_run < $num_runs} {
# if { $i_run == 0 } {
# minimize 100
# run 100
# }
  if { $i_run % 2 == 0 } {
    set swap a; set other b
  } el..."
    (file "rest2_remd.namd" line 106)
    invoked from within
"source rest2_remd.namd "
    invoked from within
"if { ! [catch numPes] } { source rest2_remd.namd }"
    (file "job0.conf" line 4)

application called MPI_Abort(comm=0x84000004, 1) - process 0

Than you so much!!!
Yuwei

________________________________
From: Chitrak Gupta <chgupta_at_mix.wvu.edu>
Sent: 23 October 2019 04:47
To: Chandni Tiwari <chandni.tiwari_at_monash.edu>
Cc: Han, Yuwei <yuwei.han17_at_imperial.ac.uk>; namd-l_at_ks.uiuc.edu <namd-l_at_ks.uiuc.edu>
Subject: Re: namd-l: Need help with errors in REST2 sample file

Hi Yuwei,

Looks like you had not set those parameters in your configuration file. The meaning of these parameters is explained in the NAMD 2.13 user guide (search for the REST2 section). That should clear up most of your confusion.

Best,
Chitrak.

On Tue, Oct 22, 2019 at 3:49 PM Chandni Tiwari <chandni.tiwari_at_monash.edu<mailto:chandni.tiwari_at_monash.edu>> wrote:
Hi Yuwei,

Maybe share the configuration file as well.

On Tue, 22 Oct 2019 at 14:34, Han, Yuwei <yuwei.han17_at_imperial.ac.uk<mailto:yuwei.han17_at_imperial.ac.uk>> wrote:
Hey, I am a fresh user of NAMD. These days, I was trying to use the rest2 program in NAMD 2.13. I think I met some problems with repeating the example file from lib/replica/REST2, and the script file is lib/replica/REST2/rest2_remd.namd. I followed the tutorial from follow the README.txt file in lib/replica directory. The following is the problem I met:

Info: Configuration file is job0.conf
Info: Working in the current directory /share1/home/hanyw/NAMD/REMD-60%/REST2/REST2
TCL: Reduction callback proc set to save_callback
TCL: Suspending until startup complete.
ERROR: The following variables were set in the
ERROR: configuration file but are NOT VALID
ERROR: soluteScalingFactor
ERROR: soluteScalingAll
ERROR: soluteScalingFile
ERROR: soluteScalingCol
ERROR: soluteScaling
FATAL ERROR: ERROR(S) IN THE CONFIGURATION FILE

I am pretty new to this area, I know that it might be easy for you to deal with it. However, for me, this example has bothered me for a few days. May I ask what should I do based on this?

Thank you so much!!
Best
Yuwei

--
Regards
Chandni Tiwari

This archive was generated by hypermail 2.1.6 : Sat Dec 07 2019 - 23:20:52 CST