Re: mpirun was unable to find the specified executable file

From: Roshan Shrestha (roshanpra_at_gmail.com)
Date: Fri Aug 02 2019 - 10:13:24 CDT

Using namd2 command instead of namd alone should solve the issue I guess.
Best regards

On Fri, 2 Aug 2019, 20:48 mariano spivak, <mariano_at_ks.uiuc.edu> wrote:

> Hi, I believe that the problem is that the command that you want is not
> "namd".
> Try in the terminal: which namd
> If it does not find the command, then you might want to try "namd2"
> instead.
> Otherwise you should find where NAMD is installed and write the full path
> in the mpirun call.
>
> Best
>
> Mariano Spivak, Ph.D.
>
> Theoretical and Computational Biophysics Group
>
> Beckman Institute, University of Illinois.
>
> mariano_at_ks.uiuc.edu
>
> mspivak_at_illinois.edu
>
>
> On Fri, Aug 2, 2019 at 8:29 AM Adupa Vasista <adupavasista_at_gmail.com>
> wrote:
>
>> Dear NAMD users
>>
>> I am learning replica-exchange umbrella sampling MD. I am using the
>> tutorial files. I copied umbrella.namd file into my working directory.
>>
>> Tutorial says to use the command "mpirun -np 4 namd +replicas 4
>> job0.conf +stdout output/%d/job0.%d.log"
>>
>> But when i execute it the error is as follows :
>>
>> -------------------------------------------------------------------------------------------------------
>> mpirun was unable to find the specified executable file, and therefore
>> did not launch the job. This error was first reported for process
>> rank 0; it may have occurred for other processes as well.
>>
>> NOTE: A common cause for this error is misspelling a mpirun command
>> line parameter option (remember that mpirun interprets the first
>> unrecognized command line token as the executable).
>>
>> Node: vasi
>> Executable: namd
>>
>> -----------------------------------------------------------------------------------------------------------
>>
>> job0.conf file details are as follows :
>>
>> ------------------------------------------------------------------------------------------------------------
>> source stretch_alanin.conf
>>
>> # prevent VMD from reading umbrella.namd by trying command only NAMD has
>> if { ! [catch numPes] } { source ./umbrella.namd }
>>
>> ------------------------------------------------------------------------------------------------------------
>>
>> Can anyone point out the mistake I am making?
>>
>> Thank You in advance.
>>
>>
>>
>>

This archive was generated by hypermail 2.1.6 : Wed Dec 11 2019 - 23:21:01 CST