Re: does any body know why GPU Acceleration not work on Windows?

From: Bryan Roessler (bryanroessler_at_gmail.com)
Date: Fri Jun 28 2019 - 14:52:47 CDT

Have you disabled Windows Defender and other anti-virus/anti-malware
programs for testing? Windows Defender loves screwing around with HPC
programs.

On Fri, Jun 28, 2019 at 4:07 AM Norman Geist <norman.geist_at_uni-greifswald.de>
wrote:

> Could you compare the SMP performance of CPU only between linux and
> windows?
>
>
>
> *Von:* owner-namd-l_at_ks.uiuc.edu [mailto:owner-namd-l_at_ks.uiuc.edu] *Im
> Auftrag von *Milad Lagzian
> *Gesendet:* Freitag, 28. Juni 2019 09:36
> *An:* Norman Geist <norman.geist_at_uni-greifswald.de>; namd-l_at_ks.uiuc.edu
> *Betreff:* Re: namd-l: does any body know why GPU Acceleration not work
> on Windows?
>
>
>
> Dear Norman
>
>
>
> The time is considerably reduced when the GPU was used ( up to 2 time
> faster in compare to WO GPU). However this was attained only by 30% of GPU
> power. We need to used the all of it. We set the command to use all 16
> cores. 16 cores are used but only at near 40% of their full capacity.
>
>
>
> :(
>
>
>
> On Fri, Jun 28, 2019 at 11:54 Norman Geist <norman.geist_at_uni-greifswald.de>
> wrote:
>
> Interpreting pure GPU utilization isn’t really a good option.
>
> What is the timing difference (ns/day) with and without GPU?
>
> Are you using as much CPU cores as under Linux?
>
>
>
> Regards
>
> Norman Geist
>
>
>
> *Von:* owner-namd-l_at_ks.uiuc.edu [mailto:owner-namd-l_at_ks.uiuc.edu] *Im
> Auftrag von *Pratik Narain Srivastava
> *Gesendet:* Freitag, 28. Juni 2019 09:18
> *An:* namd-l_at_ks.uiuc.edu; Miro Astore <miro.astore_at_gmail.com>
> *Betreff:* Re: namd-l: does any body know why GPU Acceleration not work
> on Windows?
>
>
>
> The counter question is that why on earth are you using something as bad
> as windows for research work. Just switch to linux and it works like a
> charm.
>
>
>
> On Fri, 28 Jun, 2019, 10:53 AM Miro Astore, <miro.astore_at_gmail.com> wrote:
>
> I have had this issue as well, I ran into so many issues with vmd and namd
> on windows that I eventually switched to windows. I am running namd on
> linux and get about 70% utilisation.
>
>
>
> Sorry I couldn't be more helpful.
>
>
>
> On Fri, 28 Jun 2019 at 15:15, Milad Lagzian <milad.lagzian_at_gmail.com>
> wrote:
>
> Dear all,
>
>
>
> I ask this question before, but unfortunately, no one answered. I have
> seen that some other guys have the same problem.
>
>
>
> Why GPU acceleration of NAMD_CUDA does not work on windows OS? No matter
> what system we use, only around 10% of GPU is engaged in a calculation.
>
>
>
> There is no problem with the CPU version of NAMD.
>
>
>
> All drivers have installed and tested including the latest CUDA toolkit
> and runtime, GPU and ...
>
>
>
> It seems it is the program issue.
>
>
>
> Any suggestion?
>
>

This archive was generated by hypermail 2.1.6 : Sun Sep 15 2019 - 23:20:38 CDT