Re: compiling infiniband version of NAMD

From: Aravinda Munasinghe (aravinda1879_at_gmail.com)
Date: Wed Jun 19 2019 - 10:17:07 CDT

What compilers did you use to compile charmrun?(Intel or gnu). I have come
across this communication error wihin charmrun when compiling for
infiniband with Intel.
Best,

On Wed, Jun 19, 2019, 8:43 AM Kosar Khajeh <khajeh.k.2005_at_gmail.com> wrote:

> Hello all dear NAMD developers
> I tried to compile the infiniband version of NAMD based on the "note" file.
> cd charm-6.7.1
> ./build charm++ verbs-linux-x86_64 --with-production
> cd verbs-linux-x86_64/tests/charm++/megatest
> make pgm
> ./charmrun ++mpiexec +p4 ./pgm (uses mpiexec to launch processes)
> cd ../../../../..
>
> unfortunately, I received below error while i am trying to test the charm;
>
> Charmrun> scalable start enabled.
> Charmrun> IBVERBS version of charmrun
> Charmrun> error attaching to node '127.0.0.1':
> Socket closed before recv.
>
>
> I used the "
>
> sudo apt-get install libibverbs-dev"
>
> to solve the problem.
>
> However it did not work.
>
> Any help is appreciated.
>
> Best regards
>
> Kosar
>
>

This archive was generated by hypermail 2.1.6 : Sun Dec 08 2019 - 23:20:44 CST