Re: Need help with psfgen : psfgen can't read file.pdb

From: Brian Radak (brian.radak_at_gmail.com)
Date: Tue May 07 2019 - 08:16:01 CDT

I am not a topotools expert (in fact, not even a user), but I know psfgen
pretty well -- what is this section of the script intended to accomplish?
It doesn't do anything useful that I'm aware of.

package require psfgen
resetpsf
topology top_all27_prot_lipid.rtf
readpsf zgnr_f2.psf
coordpdb zgnr_f2.pdb
writepsf zgnr_f3.psf
writepdb zgnr_f3.pdb

Note that coordpdb is meant to read in coordinates for a *segment* and has
a segment argument that is that segment name (or defaults to the last new
segment, which is null here). I think what you want is instead:

readpsf zgnr_f2.psf pdb zgnr_f2.pdb

but again, I'm not sure why you would want/need to do this.

HTH,
BKR

On Mon, May 6, 2019 at 9:55 PM Priyanka Mondal <pmondal_at_udel.edu> wrote:

> Hello all,
> I am trying to create zgnr ribbon with dangling bonds passivated by
> H-atoms. I created ZGNR using nanotube builder and imported zgnr.xyz to
> quantumatk to add passivated H-atom and then imported final structure back
> to vmd as zgnr_H.xyz. Now I created zgnr_f.pdb and zgnr_f.psf using
> following command :
>
> % **********************************************************************
> mol delete all
> mol load xyz zgnr_H.xyz
> package require topotools
> set sel [atomselect top all]
> topo guessangles
> topo guessdihedrals
> topo guessimpropers
> topo guessbonds
> $sel writepsf zgnr_f.psf
> $sel writepdb zgnr_f.pdb
>
> mol delete all
> mol load psf zgnr_f.psf pdb zgnr_f.pdb
> % **********************************************************************
>
> The files zgnr_f.psf and zgnr_f.pdb (just created) have fixed residue
> number 1 for all res GRA (which is different from residue number increasing
> in ascending order when I created zgnr.psf without H-atom directly from
> nanotube builder (i.e. no quantumatk) followed by a successful MD run).
>
> % **********************************************************************
> mol delete all
> mol load psf zgnr_f.psf pdb zgnr_f.pdb
> set sel [atomselect top all]
> $sel set segid SHT
> $sel set resname GRA
> animate write psf zgnr_f2.psf waitfor all
> animate write pdb zgnr_f2.pdb waitfor all
>
> mol delete all
> package require psfgen
> resetpsf
> topology top_all27_prot_lipid.rtf
> readpsf zgnr_f2.psf
> coordpdb zgnr_f2.pdb
> writepsf zgnr_f3.psf
> writepdb zgnr_f3.pdb
> % **********************************************************************
>
> Next when I try to use psfgen to read it using above commands, the output
> zgnr_f3.pdb sets all coordinates as zero. I looked up some similar
> questions and tried setting segname and resname as mentioned above but
> nothing worked. I am not sure how to fix it. I really hope that someone
> helps me solve this issue. I am not sure what to do. Thank you.
> Priyanka Mondal,
> Department of Physics and Astronomy,
> University of Delaware,
> USA
>

This archive was generated by hypermail 2.1.6 : Wed Sep 18 2019 - 23:20:59 CDT