Re: NAMD support for lone pairs

From: Brian Radak (brian.radak_at_gmail.com)
Date: Tue Mar 12 2019 - 11:55:21 CDT

Oh, that is a significant caveat. So CHARMM does not actually correctly
flag the lonepair without the bond? That could be construed as a bug in
CHARMM IMO.

Once again, you've certainly given us a lot of information to make this
steadier going forward - Thanks Tabitha!

On Tue, Mar 12, 2019 at 12:11 PM Tabitha Nobel <hydrargyrumate_at_gmail.com>
wrote:

> I'm not sure if the error is with CGenFF or rather with how the PSF file
> is generated. When updating VMD's psfgen to support lone pairs, it should
> just be a matter of ensuring that there is an explicit bond present in the
> PSF.
> Thanks a lot Brian for your help!
>
> Also replying to JC's comment, it would be worth following up with the
> others. While CHARMM didn't crash with the PSF without the explicit lone
> pair bond, the lone pair didn't stay colinear with its parent chlorine
> atom.
>
>
>
> On Tue, Mar 12, 2019 at 6:35 AM Gumbart, JC <gumbart_at_physics.gatech.edu>
> wrote:
>
>> Are you sure that it’s not an error in CGenFF or some other oversight? I
>> have trouble imagining them putting a free lone pair in there. That CHARMM
>> doesn’t crash probably just means no one thought to check it. I would
>> follow up with Alex et al. before writing a lot of code to support it.
>>
>> Best,
>> JC
>>
>> On Mar 12, 2019, at 8:50 AM, Brian Radak <brian.radak_at_gmail.com> wrote:
>>
>> Tabitha,
>>
>> Thanks for updating us with the results
>> of those tests! Apparently my previous guess regarding atom order was
>> incorrect (though I will still contend this is a good idea and best
>> practice).
>>
>> To summarize - NAMD does not appear to like PSFs that do not contain an
>> explicit bond to lonepairs, but CHARMM accepts them just fine. The
>> canonical force fields appear to always include those bonds, but CGenFF may
>> not when adding a lonepairs on chlorine (any halogen?). The developers will
>> have to discuss how best to address this odd edge case.
>>
>> Thanks for working through this with us,
>>
>> Brian
>>
>> On Mon, Mar 11, 2019, 9:01 PM Tabitha Nobel <hydrargyrumate_at_gmail.com>
>> wrote:
>>
>>> Adding the bond indices and incrementing the NBOND count by one worked!
>>> I tried it also on the PSF/PDB pair that did not have the lone pair close
>>> to its parent, and that worked as well. The results of the minimization
>>> look reasonable.
>>>
>>> On Mon, Mar 11, 2019 at 5:27 PM Brian Radak <brian.radak_at_gmail.com>
>>> wrote:
>>>
>>>> That's odd. The BOND command in the Residue definition should cause the
>>>> PSF to have a bond entry - regardless the ordering.
>>>>
>>>> You can try adding a manual bond by incrementing the ! NBOND count by
>>>> one and adding two extra bond indices to the list (note that the PSF
>>>> indices start at one). This is not an ideal solution, but hopefully it will
>>>> work.
>>>>
>>>> Can you send me your initial pdb offline so that I can play with this?
>>>> We are looking to support this kind of construction in psfgen and this kind
>>>> of lonepair support might be one of the first things we can get going.
>>>>
>>>>
>>>> On Mon, Mar 11, 2019, 7:51 PM Tabitha Nobel <hydrargyrumate_at_gmail.com>
>>>> wrote:
>>>>
>>>>> Hi Brian,
>>>>>
>>>>> I tried renumbering the atoms in my PSF and PDB file as you suggested--000000000000b22fe70583e88ebc--

This archive was generated by hypermail 2.1.6 : Mon Sep 16 2019 - 23:20:25 CDT