Re: Error in using the QMElecEmbed keyword

From: Marcelo C. R. Melo (melomcr_at_gmail.com)
Date: Mon Jan 07 2019 - 13:07:28 CST

Hi again,
It seems like you ran the simulation with QMElecEmbed set to on, and then,
using the same qmBaseDir and the same qmConfigLine, you ran the simulation
with QMElecEmbed set to off.
Having the same qmConfigLine containing the "QMMM" keyword means MOPAC was
still looking for electrostatic embedding information (which you correctly
pointed out is in the file "mol.in"). Using the same qmBaseDir means the
mol.in file created in the first run was still present in the directory
when you turned off QMElecEmbed (NAMD did not write the file the second
time around, but the file was already there for MOPAC to find).

NAMD does *not* erase the qmBaseDir at every step because in MD
simulations, at every step, MOPAC (and ORCA and other QM codes) will write
temporary files that can be read in the following step to speed up
calculations.
If you are running tests like these, you should change the qmConfigLine to
tell the QM software *not* to run an electrostatic embedding calculation,
and preferably also clean the qmBaseDir.

Hope this helps,
Best,
Marcelo

---
Marcelo Cardoso dos Reis Melo
PhD Candidate
Luthey-Schulten Group
University of Illinois at Urbana-Champaign
crdsdsr2_at_illinois.edu
+1 (217) 244-5983
On Fri, 4 Jan 2019 at 12:15, Xi Chen <xichen930108_at_email.arizona.edu> wrote:
> Hi All:
>     I have been trying to run QM/MM simulation with NAMD-MOPAC, using PM7
> method, on a small test system (one alanine in a square water box). As
> described in full detail in another question posted previously, I kept
> running into chemically incorrect simulation:
>
> http://www.ks.uiuc.edu/Research/namd/mailing_list/namd-l.2018-2019/1389.html
>      I tried tuning keywords controlling the QM/MM simulation, and this
> post is specifically for the wrong results I have when tuning the keyword
> QMElecEmbed , which controls whether or not MOPAC will take classical point
> charges into consideration for QM calculations.
>     As far as I know, MOPAC takes into account the classical point charges
> by reading in a file called "mol.in", which should appear in the
> directory specified in qmBaseDir. The trouble I have is that, I tried run
> two 0 step (so that MOPAC is only invoked once by NAMD) simulations from
> the same starting structure with QMElecEmbed  set to on, and to off,
> separately,  but their "mol.in" file and result file ".aux" file were
> identical to each other, meaning that tuning this keyword does not change
> anything to my system. You can find my starting pdd, psf, topology files
> and output files in this url:
> http://schwartzgroup1.arizona.edu/~dimitri/ele.tar
>     In which, "mol.in_on" and ".aux_on" are results from the simulation
> where QMElecEmbed  is set to on, "mol.in_off" and ".aux_off" are results
> from the simulation where QMElecEmbed  is set to off. Unzip and run
> ele.namd should be able to reproduce my result. Do check directories for
> NAMD executable, MOPAC and qmBaseDir.
>     Any help will be appreciated. Thank you in advance!
>
> Xi Chen
> PhD Candidate, Schwartz Group
> Department of Chemistry and Biochemistry
> University of Arizona
>

This archive was generated by hypermail 2.1.6 : Sun Dec 08 2019 - 23:20:21 CST