Re: Running on GPU

From: Vermaas, Joshua (Joshua.Vermaas_at_nrel.gov)
Date: Mon Mar 12 2018 - 14:46:57 CDT

Hi Mahmood,

NAMD uses both the CPUs and the GPUs for computation, and right now, it
looks like you are limited by your CPUs. I have two concrete
recommendations:

1.) Use one of the nightly versions of NAMD. Specifically, you want a
version newer than March 30th of last year, when Antti-Pekka added
bonded calculations to the list of things the GPU could do. This reduces
the burden on the CPU, making simulations run faster when they are
CPU-bound as yours are.

2.) Drop the idlepoll. That option was required in NAMD 2.9, but newer
versions behave better without it in my experience.

-Josh

On 03/12/2018 01:27 PM, Mahmood Naderan wrote:
> Hi,
> Previously I asked about gpu utilization of my namd run. Still I have
> problem and I need some hints to see what is what. According to the
> manual [1], I used the following command
>
>
> namd2 +idlepoll +p4 +devices 0 ubq_ws_eq.conf
>> namd2_idlepoll_p4_devices_0.txt
>
> The full output is available at https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fpastebin.com%2FMbp8N2h4&data=02%7C01%7CJoshua.Vermaas%40nrel.gov%7C265265db7af14f75b83b08d5884f539e%7Ca0f29d7e28cd4f5484427885aee7c080%7C0%7C0%7C636564796648542795&sdata=h%2FtyAnpe7%2BsBC0YJtFdV41gke43zBoCcBbzxSGm95es%3D&reserved=0
>
> As you can see in the log the GPU is detected. During the run, I see
> 400% CPU utilization, while nvidia-smi reports about 15% GPU
> utilization while a namd2 process with 100MB is there on the gpu.
>
> Any idea? Any idea is appreciated. I have stuck!
>
>
> +-----------------------------------------------------------------------------+
> | Processes: GPU Memory |
> | GPU PID Type Process name Usage |
> |=============================================================================|
> | 0 1137 G /usr/lib/xorg/Xorg 158MiB |
> | 0 1616 G compiz 47MiB |
> | 0 3687 C namd2 104MiB |
> +-----------------------------------------------------------------------------+
> Mon Mar 12 22:46:23 2018
> +-----------------------------------------------------------------------------+
> | NVIDIA-SMI 384.81 Driver Version: 384.81 |
> |-------------------------------+----------------------+----------------------+
> | GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
> | Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
> |===============================+======================+======================|
> | 0 Quadro M2000 Off | 00000000:23:00.0 On | N/A |
> | 56% 46C P0 26W / 75W | 324MiB / 4035MiB | 11% Default |
> +-------------------------------+----------------------+----------------------+
>
>
>
>
> [1] https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.ks.uiuc.edu%2FResearch%2Fnamd%2F2.9%2Fug%2Fnode88.html&data=02%7C01%7CJoshua.Vermaas%40nrel.gov%7C265265db7af14f75b83b08d5884f539e%7Ca0f29d7e28cd4f5484427885aee7c080%7C0%7C0%7C636564796648542795&sdata=7M23Zc831C5lA1g526aclTKWjyZqvF6lKKrDiPRVicg%3D&reserved=0
>
>
>
> Regards,
> Mahmood
>
>

This archive was generated by hypermail 2.1.6 : Tue Sep 17 2019 - 23:19:42 CDT