Re: Segmentation fault for the tutorial

From: Vermaas, Joshua (Joshua.Vermaas_at_nrel.gov)
Date: Wed Mar 07 2018 - 12:30:36 CST

Hi Mahmood,

Is there a particular reason you are compiling this yourself? Looking
back at the thread, it looks like you are trying to build a
multicore-CUDA build, which are distributed as a binary on the website.
I find it to be much easier to deal with than compiling it myself. To
get back to your point though, the nightly builds use a newer version of
charm, which is why having a built 6.7.1 doesn't help when the makefile
is looking for a 6.8.2.

-Josh

On 03/07/2018 11:08 AM, Mahmood Naderan wrote:
> Excuse me... I decided to use the charm tar file from the namd-2.12
> source package. I ran the following commands
>
> cd namd
> cd charm-6.7.1
> ./build charm++ multicore-linux64 --with-production
> cd multicore-linux64/tests/charm++/megatest
> make pgm
> ./pgm +p4
> cd ../../../../..
> tar xzf fftw-linux-x86_64.tar.gz
> mv linux-x86_64 fftw
> ./config Linux-x86_64-g++ --charm-arch multicore-linux64 --with-cuda
> --cuda-prefix /usr/local/cuda-9.0 --with-tcl --tcl-prefix
> /home/mahmood/namd-2.12/namd/tcl-threaded
> cd Linux-x86_64-g++
> make -j4
>
>
>
> For the last command, the full output is
>
> mahmood_at_orca:Linux-x86_64-g++$ make -j4
> if [ ! -d inc ]; then mkdir -p inc; fi
> if [ ! -d obj ]; then mkdir -p obj; fi
> gcc -m64 -O3 -Isrc -I/home/mahmood/namd-2.12/namd/tcl-threaded/include
> -DNAMD_TCL -fexpensive-optimizations -ffast-math
> -DNAMD_VERSION=\"2.12\"
> -DNAMD_PLATFORM=\"Linux-x86_64-multicore-CUDA\"
> -DREMOVE_PROXYRESULTMSG_EXTRACOPY -DNODEAWARE_PROXY_SPANNINGTREE
> -DUSE_NODEPATCHMGR -DBONDED_CUDA -DUSE_HOMETUPLES -o flipdcd
> src/flipdcd.c || \
> echo "#!/bin/sh\necho unavailable on this platform" > flipdcd; \
> chmod +x flipdcd
> gcc -m64 -O3 -Isrc -I/home/mahmood/namd-2.12/namd/tcl-threaded/include
> -DNAMD_TCL -fexpensive-optimizations -ffast-math
> -DNAMD_VERSION=\"2.12\"
> -DNAMD_PLATFORM=\"Linux-x86_64-multicore-CUDA\"
> -DREMOVE_PROXYRESULTMSG_EXTRACOPY -DNODEAWARE_PROXY_SPANNINGTREE
> -DUSE_NODEPATCHMGR -DBONDED_CUDA -DUSE_HOMETUPLES -o flipbinpdb
> src/flipbinpdb.c || \
> echo "#!/bin/sh\necho unavailable on this platform" > flipbinpdb; \
> chmod +x flipbinpdb
> make: *** No rule to make target
> '/Projects/namd2/charm-6.8.2/multicore-linux64/bin/charmrun', needed
> by 'charmrun'. Stop.
> make: *** Waiting for unfinished jobs....
> if [ ! -f inc/.exists ]; then touch inc/.exists; fi
> if [ ! -f obj/.exists ]; then touch obj/.exists; fi
> src/flipdcd.c: In function ‘main’:
> src/flipdcd.c:42:3: warning: implicit declaration of function ‘exit’
> [-Wimplicit-function-declaration]
> exit(-1);
> ^
> src/flipdcd.c:42:3: warning: incompatible implicit declaration of
> built-in function ‘exit’
> src/flipdcd.c:42:3: note: include ‘<stdlib.h>’ or provide a
> declaration of ‘exit’
> src/flipdcd.c:47:9: warning: implicit declaration of function
> ‘strncmp’ [-Wimplicit-function-declaration]
> if ((strncmp(argv[argcount],"-S",2) == 0) ||
> (strncmp(argv[argcount],"-s",2) == 0)){
> ^
> src/flipbinpdb.c: In function ‘main’:
> src/flipbinpdb.c:30:3: warning: implicit declaration of function
> ‘exit’ [-Wimplicit-function-declaration]
> exit(-1);
> ^
> src/flipbinpdb.c:30:3: warning: incompatible implicit declaration of
> built-in function ‘exit’
> src/flipbinpdb.c:30:3: note: include ‘<stdlib.h>’ or provide a
> declaration of ‘exit’
> src/flipbinpdb.c:35:3: warning: incompatible implicit declaration of
> built-in function ‘exit’
> exit(-1);
> ^
> src/flipbinpdb.c:35:3: note: include ‘<stdlib.h>’ or provide a
> declaration of ‘exit’
> src/flipbinpdb.c:40:3: warning: incompatible implicit declaration of
> built-in function ‘exit’
> exit(-1);
> ^
> src/flipbinpdb.c:40:3: note: include ‘<stdlib.h>’ or provide a
> declaration of ‘exit’
> src/flipbinpdb.c:47:3: warning: incompatible implicit declaration of
> built-in function ‘exit’
> exit(-1);
> ^
> src/flipbinpdb.c:47:3: note: include ‘<stdlib.h>’ or provide a
> declaration of ‘exit’
> src/flipbinpdb.c:53:3: warning: incompatible implicit declaration of
> built-in function ‘exit’
> exit(-1);
> ^
> src/flipbinpdb.c:53:3: note: include ‘<stdlib.h>’ or provide a
> declaration of ‘exit’
> src/flipbinpdb.c:64:1: warning: incompatible implicit declaration of
> built-in function ‘exit’
> exit(0);
> ^
> src/flipbinpdb.c:64:1: note: include ‘<stdlib.h>’ or provide a
> declaration of ‘exit’
>
>
>
>
>
>
>
> Please note the line which says
>
> make: *** No rule to make target
> '/Projects/namd2/charm-6.8.2/multicore-linux64/bin/charmrun', needed
> by 'charmrun'. Stop.
>
>
> Any idea?
> Regards,
> Mahmood
>
>
>
>
> On Wed, Mar 7, 2018 at 9:08 PM, Mahmood Naderan <mahmood.nt_at_gmail.com> wrote:
>> David,
>> I cloned that. Previously I ran config with --with-charm-arch according to
>> the manual. Also charm tar was there in the namd source.
>>
>> I don not see that now. Is it fine to drop the charm option in config?
>>
>> Regards,
>> Mahmood
>>
>

This archive was generated by hypermail 2.1.6 : Sat Dec 14 2019 - 23:19:38 CST