Re: Segmentation fault for the tutorial

From: Mahmood Naderan (mahmood.nt_at_gmail.com)
Date: Wed Mar 07 2018 - 11:38:44 CST

David,
I cloned that. Previously I ran config with --with-charm-arch according to
the manual. Also charm tar was there in the namd source.

I don not see that now. Is it fine to drop the charm option in config?

Regards,
Mahmood

On Wed, Mar 7, 2018 at 8:21 PM, David Hardy <dhardy_at_ks.uiuc.edu> wrote:
> Hi Mahmood,
>
> It looks like you are building from the NAMD 2.12 released source back in
> Dec 2016.
>
> Unfortunately, the new CUDA kernels released at that time introduced a bug
> in which MSM was not getting properly initialized, hence the seg fault you
> are seeing. The bug was discovered and fixed around March 2017.
>
> See this earlier namd-l thread regarding the problem (and there are
others):
> http://www.ks.uiuc.edu/Research/namd/mailing_list/
namd-l.2017-2018/0747.html
>
> Since you are building NAMD, why not use an up-to-date version of the
> source? You can get it with this command:
> git clone https://charm.cs.illinois.edu/gerrit/namd.git
>
> (Besides which, support for CUDA 9 was not even possible back in 2016.)
>
> See http://www.ks.uiuc.edu/Research/namd/development.html for more details
> on building NAMD.
>
> Best regards,
> Dave
>
> --
> David J. Hardy, Ph.D.
> Beckman Institute
> University of Illinois at Urbana-Champaign
> 405 N. Mathews Ave., Urbana, IL 61801
> dhardy_at_ks.uiuc.edu, http://www.ks.uiuc.edu/~dhardy/
>
>

This archive was generated by hypermail 2.1.6 : Wed Dec 04 2019 - 23:19:41 CST